|Re: [hatari-devel] fopen traces|
[ Thread Index |
| More lists.tuxfamily.org/hatari-devel Archives
Le 06/04/2015 19:38, Eero Tamminen a écrit :
On sunnuntai 05 huhtikuu 2015, Thomas Huth wrote:
schrieb Eero Tamminen <oak@xxxxxxxxxxxxxx>:
On tiistai 31 maaliskuu 2015, Thomas Huth wrote:
But IMHO it would be nice to have this somewhat more closely
related to the other "gemdos" trace flag. I.e. when you run
"--trace help", it should show up next to the "gemdos" flag
instead. And maybe rename it to "gemdos_fopen" ?
What if it would be named just "files"?
Reason for this is that if it's a commmonly used option,
short name is better than excessively long one...
I think it should at least have the "gemdos_" prefix to make it clear
that it belongs to the gemdos hd emulation. (If you just name it
"files" or "fopen", how is the user supposed to know that this is about
gemdos hd emulation and not ACSI, IDE, SCSI
It's NOT about GEMDOS HD emulation. Hatari supports
tracing GEMDOS calls without GEMDOS HD emulation being
enabled. I just commited support for that also for
GEMDOS fopen tracing.
or even Hatari native fopen calls?
All other trace options are for tracing what emulated code does,
so I don't think this should be a problem.
I agree with thomas, it's not about the option being commonly used or
not , but since it's part of gemdos it would be better to prefix with
gemdos_ , makes it easier to undestand IMO when you type "--trace help"
(and that's not a lot of extra letters to type :) )