Re: [hatari-devel] fopen traces

[ Thread Index | Date Index | More Archives ]


On sunnuntai 05 huhtikuu 2015, Thomas Huth wrote:
> schrieb Eero Tamminen <oak@xxxxxxxxxxxxxx>:
> > On tiistai 31 maaliskuu 2015, Thomas Huth wrote:
> > > But IMHO it would be nice to have this somewhat more closely
> > > related to the other "gemdos" trace flag. I.e. when you run
> > > "--trace help", it should show up next to the "gemdos" flag
> > > instead. And maybe rename it to "gemdos_fopen" ?
> > 
> > What if it would be named just "files"?

Reason for this is that if it's a commmonly used option,
short name is better than excessively long one...

> I think it should at least have the "gemdos_" prefix to make it clear
> that it belongs to the gemdos hd emulation. (If you just name it
> "files" or "fopen", how is the user supposed to know that this is about
> gemdos hd emulation and not ACSI, IDE, SCSI

It's NOT about GEMDOS HD emulation.  Hatari supports
tracing GEMDOS calls without GEMDOS HD emulation being
enabled.  I just commited support for that also for
GEMDOS fopen tracing.

> or even Hatari native fopen calls?

All other trace options are for tracing what emulated code does,
so I don't think this should be a problem.

	- Eero

Mail converted by MHonArc 2.6.19+