Re: [AD] New gfx api

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


Alternatively, we could introduce a global variable instead of NULL. Or #define a macro to hide NULL behind a more meaningful name.

The latter seems better; the fewer exported symbols, the better.
Something like

#define AL_GLOBAL_QUEUE      NULL

could fit well... Then we'd have an internal static queue to be used whenever NULL is specified as queue.

--
Angelo Mottola
a.mottola@xxxxxxxxxx
http://www.ecplusplus.com





Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/