Re: [AD] New gfx api

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


Angelo Mottola wrote:

Alternatively, we could introduce a global variable instead of NULL. Or #define a macro to hide NULL behind a more meaningful name.


The latter seems better; the fewer exported symbols, the better.


As you know, I disagree with this.

Something like

#define AL_GLOBAL_QUEUE      NULL

could fit well... Then we'd have an internal static queue to be used whenever NULL is specified as queue.


I thought about this more, and I don't like it. With this you can't differentiate between an intentional NULL argument meaning "global queue" from an accidental NULL argument due to a bug in the user's program.

BTW, Angelo: There's instance of select() in src/unix/utimernu.c that you should check out. And feel free to change some of the code to use vtables as you like (but not internal threading API).

Peter




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/