Re: [Sawfish] rep-gtk and gtk+

[ Thread Index | Date Index | More Archives ]

On Friday 01 July 2011 23:52:13 Stefano Sabatini wrote:
> Hi all,
> I'm trying to install rep-gtk from sources, and I see that I need gtk+
> >= 2.24. On Debian stable gtk+ is at version 2.20, so I need to
> install that from sources as well.
> Can you say which are the gtk+ requirements in terms of dependencies?
> Am I going to bust my system in case I'll install it (thus overriding
> the system libgtk+)?

I'd rather suggest you reading

than installing gtk+ manually. And >= 2.24 is not a synthetic dependency, it 
really needs atleast 2.24.0
> Which is the alternative in case I would prefer to rely on the Debian
> gtk+ (e.g. can I compile an old branch of rep-gtk and still get the
> rest of the updated sawfish properly working)?

Sawfish 1.8.x and rep-gtk << 0.90.7 will work with GTK+ 2.12,
Sawfish 1.9x (>= 1.8.90)  and rep-gtk >= 0.90.7 need 2.24.
> Many thanks in advance, best regards.


Sawfish ML

Mail converted by MHonArc 2.6.19+