Re: [eigen] Eigen appears to rock.

[ Thread Index | Date Index | More Archives ]

On Thu, Aug 21, 2008 at 8:37 AM,  <jacob@xxxxxxxxxxxxxxx> wrote:
> 100% agree with Gael.

Oh, well. :^)

> Another argument against Point is that it means more types hence more
> code instantiated for the same thing.

I think that it is not for the same thing.

> For example, the Point+Vector addition is exactly the same as
> Vector+Vector, so let's not make it generate the same code a second
> time.

The fact that Point+Vector returns Point is actually an important
difference, because the returned Point transforms differently from the
Vector, and the Point has a much smaller and different interface of
allowed operations.

By using classes like these in my own code, it has actually helped me to
clarify thoughts in my own mind (and, I think, to keep my code more

> I didn't realize that this method was called affine(). Why? To me, the
> whole 4x4 matrix is an affine transformation (which means linear
> transformation combined with translation) and the topleft 3x3 block is
> the _linear_ part.  So, how about renaming affine() to linear() ?

I agree completely.  I suggested the same thing in my other message.

You guys are great to talk to.  Thanks for giving me some time.

Thomas E. Vaughan

There are only two kinds of people; those who accept dogma and know it,
and those who accept dogma and don't know it. - G.K. Chesterton

Mail converted by MHonArc 2.6.19+