Re: [hatari-devel] Reversed actions on Reset the Emulator in Load Config option - macOS version

[ Thread Index | Date Index | More Archives ]

Le 12/02/2018 à 03:03, Bob Carpenter a écrit :

Thank you for the quick reply. That change did fix the problem. I have attached a diff file with the one line change to SDLMain.m in the src/gui-osx directory. For some reason, I have been unable to compile Hatari 2.1.0 correctly so it will use the v5 CAPSImage framework. Therefore, I will wait to see if Troed compiles a nightly macOS build that includes this change (if the change is accepted).


Thanks, I modified the source accordingly.

PS : your diff patch seems wrong, it's reversed. I think you did "diff new_file old_file", but you should do "diff old_file new_file". Also, use "diff -u" when posting patch, it gives more readable patch, with more context.


Bob C


On Feb 11, 2018, at 6:27 PM, Thorsten Otto <admin@xxxxxxxxxxx> wrote:

On Sonntag, 11. Februar 2018 23:01:42 CET Bob Carpenter wrote:
Is this something you can change easily?

That should just read...
.. == NSAlertSecondButtonReturn

It's the 2nd (alternate) button that has the "Reset" text.

Mail converted by MHonArc 2.6.19+