[eigen] Re: special matrix classes: template parameters |
[ Thread Index |
Date Index
| More lists.tuxfamily.org/eigen Archives
]
- To: eigen <eigen@xxxxxxxxxxxxxxxxxxx>
- Subject: [eigen] Re: special matrix classes: template parameters
- From: Benoit Jacob <jacob.benoit.1@xxxxxxxxx>
- Date: Sat, 14 Nov 2009 11:50:07 -0500
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type; bh=vTfJebQyKkUEvHTEM9OH+DXpXubb/n3dLG0KpdIRNJI=; b=KJ1X14F7Sl06WriLMv/OE6xkkTi5XQfGFrqVDEQ0F3eG7cl8Ibhi27tUNc3CtPlsRC ExQATPFb+gd3S2xhpEIVwcEl3vzGPHboPkFTv4ZnGNJw0DcD7Ecl7O+Q7+eXOSRsGwZU Xff4RSciXbcKq3tV8lN8HOVNdjkcp52JAQPTY=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type; b=pB8H+kIWfi3Hh4ZEd9ikvlH93vYLMa/D5lChmGGnLO6jIv5eskLNabLtTv3NqUFvXO PFMhupuCIwZQJMlrYleYbKqRqiPaPSQya/bUNm6JnH7b/HY9P5XYvFzNw7dfBbRrhHoZ beAjrb0kq4OUqGzhi/tjLgbABE7ZE9HbYPXxY=
further remarks:
- this reallows nice simplifications in the code (in ei_traits and in typedefs)
- while i'm at it, i'll let the toDense() methods use a ReturnByValue
- and I'll rename ReturnByValue to ReturnValue since that's what it is
i put that on the TODO and i take care of it now.
Benoit
2009/11/14 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
> (and the same applies to DiagonalMatrix, of course, and to
> PermutationMatrix that i am coding at the moment)
>
> 2009/11/14 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
>> Hi,
>>
>> Currently the BandMatrix class takes Scalar, Rows,Cols template
>> parametes that could be replaced by a single parameter DenseMatrixType
>> representing the return value of toDense(). Not only this would allow
>> to simplify the template parameters considerably, this would also be
>> more future proof (it could read more data from the DenseMatrixType),
>> and would allow to benefit from the MaxRowsAtCompileTime notion (for
>> dynamic-size-inside-fixed-size-storage --- that is required to ensure
>> "no malloc with fixed-size objects" in complicated use cases).
>>
>> So OK to let it take a DenseMatrixType template parameter instead? And
>> in the Options, the RowMajor stuff would also move there, so that's a
>> further simplification.
>>
>> Benoit
>>
>