[eigen] Re: special matrix classes: template parameters |
[ Thread Index |
Date Index
| More lists.tuxfamily.org/eigen Archives
]
- To: eigen <eigen@xxxxxxxxxxxxxxxxxxx>
- Subject: [eigen] Re: special matrix classes: template parameters
- From: Benoit Jacob <jacob.benoit.1@xxxxxxxxx>
- Date: Sun, 15 Nov 2009 15:27:00 -0500
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=KeADT0E34aNS8q9iRp08YVtIuTywwCf3+GH0ShBR6YI=; b=IqL4GTcZnjqo401aKjG1CxOodSdGz+bO7ueK+7AVtZvlOI9WUeQw7lzQUAILlla0nU GMCbncNBJsLa+u8mExCSIT6KxQctaWyVDD8ejIekQp0cH9AkWaGX5kHDwZold70Xs+91 BDWfyDhTKi3B1+wEGB4Dk5YycKDPBnycVFkVg=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=FFy07jLmLnL3rQpLdZBA5QHRv9DE0b47eg0oENy7Z3C2aFqRDXQ26xEjdkhErqeiyw cJeTlzwYh/L0xEL7yqj8XfxBqP9LyiN0p9c/TjttnQsPTNMYkAureiz8/yeR8fLmjR1p iKmITu4+7x27HF/HKUtyiL+AMLsQl9gCOXh2Q=
argh.
i think i'm not going to make this change after all. It feels too
weird to have these special matrix classes relying on a dense matrix
class. It seems better after all to keep the different base matrix
classes on an equal footing.
instead i'll add "AtCompileTime" parameters... even though they only
are useful for the toDenseMatrix() method. at least that will be
homogeneous with Matrix
Benoit (very frustrated)
2009/11/14 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
> further remarks:
> - this reallows nice simplifications in the code (in ei_traits and in typedefs)
> - while i'm at it, i'll let the toDense() methods use a ReturnByValue
> - and I'll rename ReturnByValue to ReturnValue since that's what it is
>
> i put that on the TODO and i take care of it now.
>
> Benoit
>
> 2009/11/14 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
>> (and the same applies to DiagonalMatrix, of course, and to
>> PermutationMatrix that i am coding at the moment)
>>
>> 2009/11/14 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
>>> Hi,
>>>
>>> Currently the BandMatrix class takes Scalar, Rows,Cols template
>>> parametes that could be replaced by a single parameter DenseMatrixType
>>> representing the return value of toDense(). Not only this would allow
>>> to simplify the template parameters considerably, this would also be
>>> more future proof (it could read more data from the DenseMatrixType),
>>> and would allow to benefit from the MaxRowsAtCompileTime notion (for
>>> dynamic-size-inside-fixed-size-storage --- that is required to ensure
>>> "no malloc with fixed-size objects" in complicated use cases).
>>>
>>> So OK to let it take a DenseMatrixType template parameter instead? And
>>> in the Options, the RowMajor stuff would also move there, so that's a
>>> further simplification.
>>>
>>> Benoit
>>>
>>
>