Re: [eigen] How to resize a partially fixed matrix |
[ Thread Index |
Date Index
| More lists.tuxfamily.org/eigen Archives
]
- To: eigen@xxxxxxxxxxxxxxxxxxx
- Subject: Re: [eigen] How to resize a partially fixed matrix
- From: Benoit Jacob <jacob.benoit.1@xxxxxxxxx>
- Date: Wed, 24 Jun 2009 20:32:23 +0200
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=kOd+ZYNK4i5xDRjcXMWxmk9ZoFXKecezxtmI6hKyabY=; b=svxo0QNM8tGnnQ5vlDCNM3uThz8DtrxOyiPN7bo6AmdrRp/tEQvQj7EuWS+TF3el4w WJ1hvXUyWsBClG1pbVMtH15iwfuuxPROLw2iaU/mkZTRSSTnw2bgGcxNVjl+WvAUXDog eZHFwNmCczO9oXiUSVHCnSIkisRbWiEbcT2yc=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=nrRdyVirQE/38qVh7PhDyDT7y9XvbS6DjhSmmtkOP6EPMmxGocenieXS+zyPOEC8GG v9QFrOI/ulYXX07oK8DOPJ3/bubkIZfvClzddChzUJjjNRqpPNaElG41kA4C79Pne8Cy Yks6pZR6rW+P2ivKzyxMnrJz5nclOgUJsWuD0=
Sounds good, API-wise.
But it should not be _required_ to construct a proxy object just to
resize a matrix. So I'm not opposed to adding this as additional
names, but we still need to devise an API within class Matrix (which
colwise().resize() would then call).
Benoit
2009/6/24 Márton Danóczy <marton78@xxxxxxxxx>:
> What about .colwise().resize() / .rowwise().resize()?
>
> 2009/6/24 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
>> 2009/6/24 Robert Bocquier <robert.bocquier@xxxxxxxxxxx>:
>>> How about a new escape constant "NoChange" (or whatever name fits), use that
>>> way :
>>>
>>> A.resize(NoChange, 7);
>>
>> That would require more runtime if's in resize(), hence a constant
>> overhead, so i'm a bit reluctant.
>>
>> roooh but while writing this i had an idea:
>>
>> how about separate resizeHoriz(int) and resizeVert() functions ???
>> It seems to me that this adresses the original request and yours simultaneously!
>>
>> In fact this is a just modification of your idea:
>> NoChange as parameter ---> NoChange as template parameter ----> separate methods
>>
>> What do you think?
>> Also for the names I don't know... initially i thought resizeRows(int)
>> but that is ambiguous, it could mean either "change the number of
>> rows" or "resize the rows"... other possibility:
>> setRows() // goes well with the accessor method rows()
>>
>> Opinions?
>>
>> Benoit
>>
>>
>>
>
>
>