|Re: [eigen] Diagonal matrices diff|
[ Thread Index |
| More lists.tuxfamily.org/eigen Archives
- To: eigen@xxxxxxxxxxxxxxxxxxx
- Subject: Re: [eigen] Diagonal matrices diff
- From: Benoit Jacob <jacob.benoit.1@xxxxxxxxx>
- Date: Sun, 10 May 2009 17:26:19 +0200
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=5v6DY+fWsSQWyY/gpgOnC2+AD8V4i3cqjEYdda4yMg8=; b=pI055vVTJeNQCJpOdqpFl3dqhUiJ6ZNBO/eN/YNhGO+Qu2OCDcEEa1pNUXoao5V9LW Xe+epyxqg93EQcDJXqHEG+0qjoXvJ2NpBhz3b8sjf7Jat9Bl6/SwMwtdk2wpxzAQsOuu sjmp75W2lrEZnvE9/iU0DbcmJutx1nELjvq3U=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=NEO900pueUycM2hQXyDMJ+R85YTGPLq2onbx4FgRmPYGos/pKsUhzZmdt0TnFAqRKy hOigypkU9XOoG1Em1WgpIKEPIf19/eTEoy5PdVhBwm47cvbn1eO88XpyexpkNZXKEgmo W+PzPQjcSwBDh+oWyGwRCJHKeSA2fDcd4k8q8=
ok, since we don't want to allow Part<Diagonal> anyway, the only way
it remains used is to check whether a given expression is diagonal
--> solution (doing it now):
remove Diagonal constant
add ei_is_diagonal<T>::ret (instead of doing the same slippery
rename DiagonalCoeffs to Diagonal, instead of Band
2009/5/10 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
> ok, thinking about it: I agree that the terminology "Band" here was
> very misleading.
> But the name "DiagonalCoeffs" was ugly.
> Ideally, we want to call that "Diagonal", but that symbol is already
> taken in Constants.h.
> Is it time to namespace the constants, a la Qt?
> 2009/5/10 Benoit Jacob <jacob.benoit.1@xxxxxxxxx>:
>> 2009/5/10 Gael Guennebaud <gael.guennebaud@xxxxxxxxx>:
>>> I did not read your patch carefully (no time right now) but initially
>>> I thought it would be better to keep DiagonalCoeffs and add a new Band
>>> class (for compilation time, more specialized API, etc...).
>> There's a misunderstanding. By "Band" I mean exactly one
>> diagonal/subdiagonal/superdiagonal. I'm using "band" as a shorter,
>> unified synonym for all that.
>> The only difference between Band and DiagonalCoeffs, is that now the
>> index (positive for superdiagonal, negative for subdiagonal) can be a
>> runtime variable.
>> When I add a class for banded matrix allowing multiple bands, I'll
>> call it "BandedMatrix".
>> Is this terminology OK?
>>> see what I wrote:
>> Yes, I read it, btw i made comments here,
>> i'd be interested in your thoughts before i do BandedMatrix.