Re: [eigen] Diagonal matrices diff

[ Thread Index | Date Index | More Archives ]

2009/5/10 Gael Guennebaud <gael.guennebaud@xxxxxxxxx>:
> Hi,
> I did not read your patch carefully (no time right now) but initially
> I thought it would be better to keep DiagonalCoeffs and add a new Band
> class (for compilation time, more specialized API, etc...).

There's a misunderstanding. By "Band" I mean exactly one
diagonal/subdiagonal/superdiagonal. I'm using "band" as a shorter,
unified synonym for all that.

The only difference between Band and DiagonalCoeffs, is that now the
index (positive for superdiagonal, negative for subdiagonal) can be a
runtime variable.

When I add a class for banded matrix allowing multiple bands, I'll
call it "BandedMatrix".

Is this terminology OK?

> see what I wrote:

Yes, I read it, btw i made comments here,
i'd be interested in your thoughts before i do BandedMatrix.


Mail converted by MHonArc 2.6.19+