Re: [AD] Feature backports for 5.0.6

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


On Sun, Feb 12, 2012 at 4:58 PM, Peter Wang <novalazy@xxxxxxxxxx> wrote:
>> al_windows_get_window_handle
>> al_windows_add_window_callback
>> al_windows_remove_window_callback
>>
>> There is some precedence for prefixing, as we do with al_ustr_*.
>
> Me too.  I would prefer al_win_*, similar to A4.
>
I've renamed them to:

al_win_add_window_callback
al_win_remove_window_callback

and hopefully fixed a bug with menus on Windows.

The commits were separated between menu code and the generic window
callback code in case that makes any difference when back porting.

al_get_win_window_handle still exists.

I suppose on 5.0 we could have

#define al_win_get_window_handle al_get_win_window_handle

or even

HWND al_get_win_window_handle(ALLEGRO_DISPLAY *d)
{
  return al_win_get_window_handle(d);
}

and then remove it in 5.1.

> GL and D3D functions would ideally be treated similarly, but
> it's probably too late for either.
>
As above, but there are a lot more of them.

--
Matthew Leverton




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/