|Re: [AD] SF.net SVN: alleg: allegro/branches/4.9|
[ Thread Index |
| More lists.liballeg.org/allegro-developers Archives
On 2010-07-02, Evert Glebbeek <eglebbk@xxxxxxxxxx> wrote:
> On 2 Jul 2010, at 3:54 , Thomas Fjellstrom wrote:
> >> While we're breaking stuff, we might as well come up with a better name.
> >> Off the top of my head:
> >> al_compose_transform
> >> al_combine_transform
> >> al_apply_tranform
> >> al_multiply_transform
> > I think I like al_apply_transform the best.
> But you'd apply it to a point (vector) not another transformation (matrix), right?
> I would prefer al_multiply_transform, since that reflects the
> underlying operation. If we think that's too "technical" and doesn't
> make sense for people who don't fully follow the underlying algebra, I
> would go with "al_combine_transform".
I like al_compose_transform the best.