Re: [AD] al_toggle_display_flag |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
- To: Coordination of admins/developers of the game programming library Allegro <alleg-developers@xxxxxxxxxx>
- Subject: Re: [AD] al_toggle_display_flag
- From: Evert Glebbeek <eglebbk@xxxxxxxxxx>
- Date: Fri, 12 Feb 2010 10:29:24 -0500
On 12 Feb 2010, at 9:41 , Elias Pschernig wrote:
> Well, so was al_toggle_window_frame() then. Should we rename it to
> al_set_display_flag()?
I guess it was.
I was thinking about al_set_display_flag(). My only concern is whether people might get confused with al_set_new_display_flags() because the names are so similar. Other than that I'm all for it.
> Well, we need the flag anyway for al_create_display (same as
> ALLEGRO_MAXIMIZED) - so it would very naturally work with just toggling
> the flag already.
It doesn't work "naturally" under OS X, because a full screen display as we implement it is a very different thing from a windowed display.
Still, I guess it'd just return false in that case.
> Unlike a resize operation they both are really just a
> flag (under X11, indeed "maximize" and "fullscreen" are just two window
> properties of the windowing system).
Not on OS X. On OS X you resize the display.
> I wouldn't mind having additional extra functions though, they could
> simply call al_toggle_display_flag.
I guess they should do either that, or call a platform-specific function in case it's not as simple as toggling a flag. Yes, the toggle_display_flag() could take care of that internally when more work is needed but I think that's a bit messy.
Evert