[AD] fshook changes

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


Over the past few months I've gotten some feedback which is good, not as much 
as I was hoping for, which is bad :(

But anyhow I have a growing TODO list for the file system code that I'd like to 
share, and see if theres anything I'm forgetting.

In no particular order:
- fix up rest of documentation, and resolve XXX comments
- change some functions to return bool, and fill in errno as necessary
- implement missing functions: al_find*, abs/rel/cannon conversions
- rename al_fs_[im](get|put)wl to al_readbitnum[lb]
  - al_fs_igetw -> al_read16l
- AL_ -> ALLEGRO_
- al_fs_readdir: have it fill in a ALLEGRO_ENTRY struct
- convert remaining parts of allegro to fshooks
  - config.c, icodec, acodec (some is done already)
- bulk rename of api to a more a5 consistent scheme:
  - al_fs_create_handle -> al_create_entry
  - al_fs_entry_name -> al_get_entry_name
  - al_fs_exists -> al_exists
- add a al_set_appname function (to be used in al_get_path, and possibly other 
places)

The bulk rename is currently at the bottom of my list, I figure it can wait 
till the rest is done.

So if anyone has any comments or suggestions, PLEASE pass them along.

-- 
Thomas Fjellstrom
tfjellstrom@xxxxxxxxxx




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/