Re: [AD] load_datafile_object using index

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


On Thu, 2005-04-21 at 14:24 +0200, spoofer255@xxxxxxxxxx wrote:
> > Well, there's create_bitmap/destroy_bitmap and so on.. so why not
> > create_datafile_index/destroy_datafile_index. It doesn't really load
> > anything in the sense of all the other load_* functions, but merely
> > creates an index from the given datafile. Only load_datafile and
> > load_datafile_object[_indexed] actually load something from that file.
> 
> That makes sense. After searching trough allegro docs I agree will
> create/destroy.
> Should I make now (final) patch or is it OK to leave that to someone else?

As you want, I won't mind a new patch of course :)

In any case, let's see if others say something about it yet, and then,
it will probably take some time before it is applied (if I'm going to do
it).. since I haven't found a way yet to properly test the
new_api_branch.



This reminds me.. would it be ok to rename the libraries in
new_api_branch, like this:

allegro/4.2
liballd-4.2.0.so
liballd.so.4.2
liballeg-4.2.0.so
liballeg.so.4.2

In the above, change 4.2 to 4.3.

For the following:

liballd.a
liballeg.a
liballd_unsharable.a
liballeg_unsharable.a

Add a 4.3 somewhere as well, I'd simply do:

liballd-4.3.a
liballeg-4.3.a
liballd_unsharable-4.3.a
liballeg_unsharable-4.3.a

I have no idea about proper unix naming conventions of libraries though.

Then, for the includes, not sure. Maybe modify allegro.h (and the other
top-level includes) to recognize an ALLEGRO_FORCE_VERSION #define, and
depending on that, include the proper sub-header. Like, at the beginning
of allegro.h:

#if ALLEGRO_FORCE_VERSION=4.3
#include <allegro4.3/allegro.h>
#else
.. the normal 4.2 allegro.h contents go here
#endif

Finally, allegro-config would be named allegro-config-4.3.

With the above changes, it would be easier to switch between 4.2 and
4.3. I'm aware that I can fiddle around with static linking and modify
modules pathes and so on.. but well, I'm just too lazy I guess. And I
seem to constantly mess things up with such a solution :P

-- 
Elias Pschernig





Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/