Re: [AD] demo of new joystick API |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
> Now, in fact. For those of you who know what I'm talking about, the API
> is the same as what I proposed on alleg-bigfive, with a few changes:
>
> 2. The concept of "sticks", i.e. collections of related axes, from
> Allegro 4 is back in. I had discarded them to make the API a bit easier
> to use, but now I think the loss in information was too much.
>
I think the joysticks of A4 is one of the sections that is the least
broken. I don't think sticks over complicates anything.
> - Function: bool al_install_joystick_driver(void)
>
Is there only going to ever be one joystick driver per platform?
It could be al_install_joystick(), as we have install_mouse(),
install_keyboard(), etc in A4. I have nothing against verbose naming,
but as long as "install" is always used in context of an overall
driver - I'm not sure "driver" is needed in the function name.
> 1. "request" & "release". I'm not sure what to call them.
> "acquire/release" was suggested but it sounds too much like
>
I think some of this will be more clear as the API evolves. I
personally would suggest the same naming convention. To me, the aspect
of grabbing a video bitmap or a joystick is similar enough that they
both could have the same prefix (acquire).
So, I'm fine with either request or aquire - but if both start popping
up all over the place in the API, it may be better to standardize on
one of them.
> 2. The name "stick" is so crappy. I'd call them "axis groups" but
> that's too long.
>
"stick" is fine to me.
Other thoughts:
What about a al_joystick_name() which returns the name of the
joystick? I don't know on what platforms/devices that's possible, but
I know some games are able to detect my MS SideWinder as such. I don't
know how they do it, but just a thought...
Also, has any thought been given on force-feedback support? I've
played around with Marcello's FF hack for A4, and it was interesting
to use.
--
Matthew Leverton