Re: [AD] Renamed API second draft |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
> >> getpixel -> al_get_pixel
> >> _getpixel -> al_get_pixel_8
> >> _getpixel15 -> al_get_pixel_15
> >> _getpixel16 -> al_get_pixel_16
> >> _getpixel24 -> al_get_pixel_24
> >> _getpixel32 -> al_get_pixel_32
> >
> > You get rid of the distinction between inline functions and regular
> > ones ?
> Not such a good idea imho, since the inline versions won't work on video
> bitmaps. The leading _ has the effect of giving you a 'be careful'
> feeling ;-)
I've always programmed to what the documentation says, not to what the
function names look like, so the trailing number would be enough for
me. Do you prefer this?
al_get_pixel
_al_get_pixel_8
_al_get_pixel_15
_al_get_pixel_16
_al_get_pixel_24
_al_get_pixel_32
I've personally always used underscores as notation for library function
names which couldn't be made static and hence made it to the user space,
who shouldn't use them even when he knew about them (because I keep them
in an internal header file). I prefer an underscore prefixed free API.
--
Grzegorz Adam Hankiewicz gradha@xxxxxxxxxx http://gradha.infierno.org/