Re: [AD] Renamed API second draft |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
On Fri, Dec 21, 2001 at 09:53:05PM +0100, Eric Botcazou wrote:
> I should have been clearer: I'd rather keep an init() and an exit()
> functions (or macros) for the initialization of the whole library, not for
> the modules. I agree that al_exit_mouse() is ugly, the pair install/remove
> is far better.
Ah, ok, I had read it too fast. Ignore the init/close and change for
install/remove. I agree with the macros too, although IIRC I haven't
included any yet.
> ... and get rid of set_uformat().
A nice idea for the next phase.
> And how do you rename getpixel() then ?
getpixel -> al_get_pixel
_getpixel -> al_get_pixel_8
_getpixel15 -> al_get_pixel_15
_getpixel16 -> al_get_pixel_16
_getpixel24 -> al_get_pixel_24
_getpixel32 -> al_get_pixel_32
> Moreover you have forgotten the other symbols prepended with an underscore
> that are part of the API: _putpixel, _ustrdup and _set_color.
Oh, I had ignored functions starting with set_*, voice_* and all the
unicode functions, I will add them in a third version, but I think it
could be done just like above with sufixes instead of prefixes.
--
Grzegorz Adam Hankiewicz gradha@xxxxxxxxxx http://gradha.infierno.org/