[Sawfish] Build Requirements (was: April 1st joke)

[ Thread Index | Date Index | More lists.tuxfamily.org/sawfish Archives ]

Christopher Roy Bratusek wrote on 01.04.2012 at 19:28:
> Hi Folks,
> we made it! According to EU-studies Sawfish is the future!

I've tried to build sawfish-1.8.92 on Ubuntu Linux 10.04 LTS 
(Lucid Lynx) following the instructions available here:


Unfortunately on this OS version the "libgtk2.0-dev" is 
version 2.20.1 but sawfish-1.8.92 requires rep-gtk >= 0.90.7 
and the NEWS file contained in rep-gtk in turn says :

  * minimum GTK+ bumped to 2.24

Why is this so?
Is there any way to avoid building also a new GTK for this

And if not which risks are there if all other prebuild
GTK applications are still using the older Gtk?

Do I really have to move to newer (and possible less stable 
platform) just to get my new Sawfish?

Regards, Peter Funk
Peter Funk, home: ✉Oldenburger Str.86, D-27777 Ganderkesee
mobile:+49-179-640-8878 phone:+49-421-20419-0 <http://www.artcom-gmbh.de/>
office: ArtCom GmbH, ✉Haferwende 2, D-28357 Bremen, Germany
DRUPA 3.5.-16.5.2012: Besuchen Sie uns in Halle 4 auf Stand B02

Sawfish ML

Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/