|Re: [eigen] Do we need geometry refactoring?|
[ Thread Index |
| More lists.tuxfamily.org/eigen Archives
- To: eigen@xxxxxxxxxxxxxxxxxxx
- Subject: Re: [eigen] Do we need geometry refactoring?
- From: Manuel Yguel <manuel.yguel@xxxxxxxxx>
- Date: Mon, 2 Aug 2010 19:40:59 +0200
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:mime-version:received:in-reply-to :references:from:date:message-id:subject:to:content-type; bh=k5nvGSh+hYo1RPFCzZpyhaqFVPzjejvPt/h92lBmWpg=; b=PtaEo0mkMQhxRHNoTLl9Lgt8q26M25OiUhSRg0ZyBgdVMnkM7syQo9wuAhdWuDhFWw FbpxYihnLI/JNN7eAMeTWGpsJYo5M7l10/ivdkQ1G2K6SGgOUC/mSkLsH6nD7DAtYmv4 Z1eF5FH7R1NgUCqFFaoS3j3K2LfGVAs5p+alk=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:from:date:message-id:subject:to :content-type; b=QwHpXhEWWalmCDvpVAniNzjxkoG90dyaSCKkg01aQj+sUL6vV7g7irsifQOp/dmc4K fgQO+m3zOoDWxknAYrG/gQlmx8q/rnv07FuMo9o6sdOoT04u5bRg2qlb41CrJuzeYaIe B925Pcz2lDKbO0JSfACRYFcq20TnSfWMKI62I=
Sorry to come late on this,
the recent changes (I guess this is this one) broke my code in the
following manner, now the product of a transform times a point (an
(n+1) x (n+1) matrix by a n vector) returns an homogeneous point aka a
This was not the case previously.
I don't know if this is on purpose but I have to know if I must fix my
code or work on a fix for the transform class.
- best regards,
On Thu, Jul 29, 2010 at 5:10 PM, Benoit Jacob <jacob.benoit.1@xxxxxxxxx> wrote:
> 2010/7/29 Hauke Heibel <hauke.heibel@xxxxxxxxxxxxxx>:
>> I pushed the following changes:
>> - Transform is now per default Projective.
>> - Improved invert() in the Transform class.
>> - RotationBase offers matrix() to be conform with Transform's naming scheme.
>> - Added Translation::translation() to be conform with Transform's naming scheme.
>> - Safeguarded some Transform functions with compile time asserts.
>> - Added missing static Identity() to Rotation2D, AngleAxis.
> Thanks a lot for getting this done. This is the attitude!
> Have you just checked that these changes are appropriately covered by
> the unit tests? Thinking especially about the inverse() code removal.
>> For the very last point, how about adding Translation::Identity() ?
> OK for that.
>> - Hauke