Re: [eigen] Diagonal matrices diff |
[ Thread Index |
Date Index
| More lists.tuxfamily.org/eigen Archives
]
- To: eigen@xxxxxxxxxxxxxxxxxxx
- Subject: Re: [eigen] Diagonal matrices diff
- From: Keir Mierle <mierle@xxxxxxxxx>
- Date: Fri, 8 May 2009 21:56:17 -0700
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:content-type :content-transfer-encoding; bh=1iLOxUUyXKpg1HCT29lLj55KGHPgcpVMCHBDOOXUPoU=; b=eUfycfXXNOim/lHujc+TSc5ZAxhKbyGUGV3sC0NUotY2p/rt8WHc75JOqlToyvJ6qU roFOsQNmnsSqpsAsFSlQqob5cq+6SbHO+giivP4uplv8n4rwQDmgTHqS2HVl5I60YCzS XvAPuJGbhYblPs/OHAfoMbKOPyJ9R7lIu7XFs=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :content-type:content-transfer-encoding; b=Au77oica1srf3A34cripHAmeD6CNXvDpXrPB89YU5kDtcEl+okpQbYOsoaztyqzQsM bMsJ+8axEFJgjmAPgzoHmWSSC8a6qNXeDykkdRzhT84HDgWOYShWlaqRrAPnpGfBMMLi 01qcxk/HTRvsBplxYMHsf3E2QR61uoryv1z5Y=
A suggestion: Instead of mailing a diff, use Rietveld to post
something for review. It's much easier to review that way instead of
the raw diff; you don't need to have eigen checked out to see the
context.
http://codereview.appspot.com/
If you have a gmail account, you can already use it. It's very easy to
post new reviews.
Keir
On Fri, May 8, 2009 at 9:17 PM, Benoit Jacob <jacob.benoit.1@xxxxxxxxx> wrote:
> Hi,
>
> before i can do the svd i need Banded matrices, for which i needed
> some improvements in DiagonalCoeffs.
> So here's a patch but as it is changing several things i thought i'd
> ask for your opinion (you know who you are) before committing.
>
> * rename DiagonalCoeffs (clumsy name) to Band. I tried first Diagonal,
> but that name was already taken by a constant Diagonal which is used
> for various things already.
> * rename the template parameter DiagId to Index.
> * keep diagonal() unchanged, returns a Band<Derived, 0>
> * rename diagonal<int>() to band<int>()
> * introduce diagonal(int), returning a Band<Derived, Dynamic>. The
> trick here is as we already do in Block : use ei_int_if_dynamic to
> store the Index in Band.
> ---> that is the improvement that i need in order to code
> BandedMatrix. No need to unroll an outer loop there, and that also
> will reduce compilation times (only one Band type instantiated).
>
> Cheers,
> Benoit
>