Re: [eigen] Bounding Volume Hierarchies

[ Thread Index | Date Index | More Archives ]

2009/3/6 Ilya Baran <baran37@xxxxxxxxx>:
> I prefer reading "(a | b) & (c | d)" to
> "(a.union(b)).intersection(c.union(d))", but it's not a strong
> preference (and, of course, your call at that).

We're very conservative against operator overloading...

> For explicit names,
> I'd suggest "union" and "intersection" for operator| and operator& and
> "unite" and "intersect" for operator|= and operator&= (rather than the
> current "extend" and "clamp").



Mail converted by MHonArc 2.6.19+