Re: [eigen] Bounding Volume Hierarchies

[ Thread Index | Date Index | More Archives ]

On Fri, Mar 6, 2009 at 8:29 PM, Benoit Jacob <jacob.benoit.1@xxxxxxxxx> wrote:
> 2009/3/6 Ilya Baran <baran37@xxxxxxxxx>:
>> I prefer reading "(a | b) & (c | d)" to
>> "(a.union(b)).intersection(c.union(d))", but it's not a strong
>> preference (and, of course, your call at that).
> We're very conservative against operator overloading...
>> For explicit names,
>> I'd suggest "union" and "intersection" for operator| and operator& and
>> "unite" and "intersect" for operator|= and operator&= (rather than the
>> current "extend" and "clamp").
> +1

"union" and "intersection" are the obvious choices, "unite" is good
too. However, "intersect" is confusing because in my brain it would
return true or false whether the two boxes intersect or not. This is
why I used "clamp". There is also "crop" , yeah, I know that's not
better... (about unite vs extend, that's because I did not thought
about unite)


Mail converted by MHonArc 2.6.19+