[AD] al_draw_polygon_with_holes, etc.

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]

How about:

  * al_draw_polygon_with_holes => al_draw_multiple_polygons
    The current name is just wrong.

  * al_draw_filled_polygon_with_holes => al_draw_cutout_polygon
    I think you can't cut out a polygon unless it is filled,
    though it breaks the "filled" pattern.

Furthermore, wouldn't it be simpler to understand if the 'holes' array
is replaced by an array of the number of vertices in each respective
polygon?  This also affects al_triangulate_polygon.

Is there a real need for the split_stride parameter to
al_triangulate_polygon?  I suggest to drop it.


Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/