Re: [AD] new proposal for *_is_* functions |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
On 2010-09-07, Elias Pschernig <elias.pschernig@xxxxxxxxxx> wrote:
> On Mon, Sep 6, 2010 at 11:27 AM, Peter Wang <novalazy@xxxxxxxxxx> wrote:
>
> > * al_is_sub_bitmap -> remove
> > A bitmap flag would be consistent with ALLEGRO_MEMORY_BITMAP, etc.
> >
> > +1
>
> We might be able to do the same for al_is_bitmap_locked and
> al_is_compatible_bitmap. For locking it should be easy, just set the flag in
> al_lock_bitmap. Not sure right now if the compatibility state of a bitmap
> can change dynamically - if yes then a flag would not work so well.
Alternatively, or additionally, we could add
ALLEGRO_BITMAP *al_get_bitmap_parent();
I'm not sure when users would want to know whether something is a
sub-bitmap, so I can't really tell if this extra information would be
useful.
> > * al_timer_is_started -> al_get_timer_started
> > Matches the other al_get_timer_* functions
> >
> > +1 But maybe Thomas has a point and al_get_timer_running (not his
> suggestion) sounds better. Would go with things like al_get_voice_playing.
True. I think having the word "start" in the name is preferable, though.
Peter