[AD] Naming conventions for OS specific functions

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


Hi all.

I've added a function to the Amiga specific version of Allegro so that
clients can query the version of the .so it resides in.  When I say
"version" I mean the Amiga version.  My friend ports games and he finds
problems (as it is a new port) so I fix them.  So we want to put checks in
at the start of ported games to make sure a new enough version of the
library is available.  ie.  Game X doesn't work with version 1.0 of the
Amiga liballegro.so but it does work with version 1.1, so we want to put a
check in to make sure that the user has a new enough version.  The function
I added for this is:

unsigned int al_get_sobj_version();

Where the upper word contains the major version and the lower word contains
the minor version.

So what I was wondering is whether there are any conventions to the naming
of OS specific functions like this?

-- 
/-------------------------------------------------------------------\
[Hitman/Code HQ - 6502/z80/68000/604e/80x86/ARM coder - Amiga rulez!]
[VZ-200/VIC-20/MZ-700/c16/c64*10/c128*8/Plus-4/CPC464/CD32/500*2    ]
[600/1000/1200*2/A4000/SNES/N64/Dreamcast/Athlon 1100/AmigaOne      ]
[Assembly Language: The most fun you can have with your clothes on! ]
\-------------------------------------------------------------------/





Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/