Re: [AD] ALLEGRO_DISPLAY_OPTIONS documentation |
[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]
Elias Pschernig wrote:
ALLEGRO_RENDER_METHOD, This should be renamed or removed, in AllegroGL it was used to force HW acceleration, but I don't see why you would have to do that. If my software rendering is fast enough to run the game, why prohibit it?
It's useful to distinguish accelerated visual from the unaccelerated ones, works only on Windows. We could only allow querying for it. It should be set to 1 and SUGGEST in any case.
ALLEGRO_SWAP_METHOD, Not sure about this one, AllegroGL doesn't seem to have it - probably we can remove it.
This one is new. It specifies a swap method involved behind al_flip_display(). I thought it would be cool to know that even though you should never rely on it.
-- Milan Mimica http://sparklet.sf.net
Mail converted by MHonArc 2.6.19+ | http://listengine.tuxfamily.org/ |