Re: [AD] Audio API on wiki

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


On Sun, 2008-02-10 at 12:42 +1100, Peter Wang wrote:
> Hi,
> 
> The new gfx API seems to be pretty solid now, so I started documenting
> the KittyCat/Milan audio API, beginning from the comments in the source
> code and filling in more details.  Since the wiki process worked well
> for the gfx API, I've put what I wrote on the wiki as well.
> 
> Speaking for myself, I'm finding the API to be quite nice.  I'm not sure
> about the OpenGL-like get/set system, which doesn't feel like the rest
> of the API.
> 

I agree - we should try to have a consistent way for this throughout
modules - if we need it at all. Like, instead of:

al_mixer_set_long(mixer, ALLEGRO_AUDIO_FREQUENCY, 48000)

it could be:

al_set_mixer_frequency(mixer, 48000)

Also, I think we decided against the al_subsystem_name naming scheme,
and instead everything should use al_verb_noun, as pointed out here:
http://wiki.allegro.cc/NewAPI/Documents/discussion_of_api_style_draft_two

So it should be al_set_mixer_long in any case.

Which reminds me of another thing, can we not use long? As it's 32 or 64
bit (and possibly something else) on various platforms, I think we just
always should use int when no explicit bit depth is required.

I think I'll add a short wiki page about these if they actually are
agreed on.

-- 
Elias Pschernig <elias@xxxxxxxxxx>





Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/