Re: [AD] 4.3 display update methods

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


One of the big issues with Allegro 4.x is that you cannot easily write
an application that runs efficiently on all OSes/platforms (see the
acquire_bitmap() debacle).

I'm not too happy with letting applications be coded in one of many
ways. This forces all drivers to implement all paths (FLIP/UPDATE) and
then hope that the driver writers can optimize all paths so they don't
suck.

IMO, what we *should* is pick *one* path and then figure out how to
optimize this in Allegro on a per-driver basis.

I favor FLIP/RETAINED, just because it can give Allegro more visibility
into what apps are potentially doing. UPDATE is, ultimately, a dead-end.
It's not in Windows Vista anymore, which just leaves a subset of X users
(and old Windows users) as the only clients. This doesn't strike me as
very compelling.


> -----Original Message-----
> From: alleg-developers-bounces@xxxxxxxxxx [mailto:alleg-
> developers-bounces@xxxxxxxxxx] On Behalf Of Peter Hull
> Sent: Wednesday, August 09, 2006 5:42 AM
> To: Coordination of admins/developers of the game programming library
> Allegro
> Subject: Re: [AD] 4.3 display update methods
> 
> On 7/24/06, Elias Pschernig <elias@xxxxxxxxxx> wrote:
> > And I'd rename them a bit, for example:
> >
> > AL_FLIP - al_flip_display will make changes visible. I guess this is
> > better than "retained", since we probably won't implement a real
> > retained mode (where only a list of primitives is stored, and then
> > executed for al_flip_display).
> >
> > AL_UPDATE - the non-retained mode. The user would respond to update
> > events with calls to al_update_rectangle, after redrawing only part
of
> > the window. This would have been most useful in the past for X11,
which
> > always was very slow (with XGL it probably won't matter anymore
though).
> >
> > Both of which could probably be combined with a "direct access"
mode,
> > where Allegro maintains an additional memory cache. So maybe an
> > AL_DIRECT which can be combined with both?
> Does everyone agree with the principle of Elias's suggestion? I'm not
> as happy with the actual names as they don't seem intuitive to me - I
> would prefer something like RETAINED/NON_RETAINED, but then I wasn't
> aware that "retained" refers specifically to storing a list of
> primitives.
> 
> Pete
> 
>
------------------------------------------------------------------------
-
> Using Tomcat but need to do more? Need to support web services,
security?
> Get stuff done quickly with pre-integrated technology to make your job
> easier
> Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
>
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
> --
> https://lists.sourceforge.net/lists/listinfo/alleg-developers
-----------------------------------------------------------------------------------
This email message is for the sole use of the intended recipient(s) and may contain
confidential information.  Any unauthorized review, use, disclosure or distribution
is prohibited.  If you are not the intended recipient, please contact the sender by
reply email and destroy all copies of the original message.
-----------------------------------------------------------------------------------




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/