Re: [AD] msvc makefile patch

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


> I think it's ok, though it looks a bit ugly... what would the
> $(SHORT_VERSION)sr look like? alleg42sr.dll &c?
> That should be fine too...
>
Short version is three letters:  allsr42.dll

Version number (42) comes after the name. (This never came up before,
because _s has no DLL associated with it.) With a bunch of IFs, it
could be made to come after the number. It was much simpler to just
redefine VERSION and let the rest alone...

Realistically, the DLL would never be used. The only time one would
really use this is to statically link Allegro with a static C runtime
to avoid all the dependancies that come with Visual C++ 8. (Although
even that would require re-building all third party libs the same
way.)

So really, the name to be most concerned about would be for the
"super" static version, which currently is: "alsrt_s.lib" or
"allsr_s.lib" if going the SHORT_VERSION route. This is why I just
appended "srt" to the version name, because things like 
"al_srt_s.lib" or "alleg_srts.lib" look dreadful.

The only way to really make them look "presentable" is to go with long
names (allegro_srt_s.lib), but that's never been the Allegro way...
And I really didn't/don't feel like making all the combinations
required to name the things out of the ordinary.

> > B) Whether INIT_CMD should exist, and if so, where should it really
> I think I would prefer to add a `dirs' target that creates the directories
> if they do not exist and add an explicit dependency on that.
>
I really have no preference how this is done. I just needed something
during build since I was trying out different naming conventions...

Also, the makefile.vc patch should be slightly altered:

   misc\embedman.bat $(subst /,\,$(DLL_NAME)) 2

Without the subst in there, the call fails.

--
Matthew Leverton




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/