`hline' and `vline' are in conflict with the curses API. How should we
fix this?
- We could handle it in the same way as we did for `clear'. We give new
names to `hline' and `vline' and put in aliases in alcompat.h, which
can be switched off by #define ALLEGRO_NO_HVLINE_ALIAS.
- We could do the same as the previous option, but NOT use the gcc
deprecation warnings. Neither the old names nor the new names would
be preferred, but the old names could be disabled.
- We could keep hline/vline as the "official" functions (what is listed
in the documentation), but internally rename them to something like
allegro_hline. Again the hline/vline wrappers would have to be
disable-able.
Peter
-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf