Re: [AD] Allegro 4.2.0 RC1 timetable

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


Only problem I can see is this:

+AL_FUNC(void *, al_dat_load_data, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_font, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_sample, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_midi, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_bitmap, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_rle_sprite, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_compiled_sprite, (PACKFILE *f, long size));
+AL_FUNC(void *, al_dat_load_xcompiled_sprite, (PACKFILE *f, long size));
+
+AL_FUNC(void, al_dat_unload_sample, (SAMPLE *s));
+AL_FUNC(void, al_dat_unload_midi, (MIDI *m));

AFAIK, we're not using a newer naming scheme until 4.3 to avoid confusion between the new API and old. IMO, the names should be left alone. Also, what's the point of the two unload functions? Wouldn't destroy_sample/destroy_midi be enough?




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/