Re: [AD] Allegro's DX mixer and the mixer core. |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
On Mon, 2004-03-22 at 11:11, Evert Glebbeek wrote:
> On Mon, Mar 22, 2004 at 02:57:22AM -0700, Thomas Fjellstrom wrote:
> > what about:
> > * al_assert::
> > * al_ffblk::
> > * al_findclose::
> > * al_findfirst::
> > * al_findnext::
> > * al_trace::
>
> Those are Allegro versions/reimplementations of library functions (assert,
> trace - ok those aren't actually functions but the name is taken) or
> platform-specific functions (findfirst/next etc). Not the same thing.
>
> > Should those not be renamed then?
>
> No, for the above reason. I do agree that it's ugly though.
>
I'd like to have al_ prefixes though. Wasn't there already concrete
plans for how it could be done, including a compatibility layer, about 1
or 2 years ago?
--
Elias Pschernig <elias@xxxxxxxxxx>