Re: [AD] to prefix or not to prefix (part 2) |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
On Mon, Oct 29, 2001 at 05:23:09PM +1100, Peter Wang wrote:
> > - Get rid of (some) global variables and states. E.g. `text_mode()'
>
> - *blit* and *sprite* are on my list. The ordering of the source and
> destination takes a while to learn, and is kinda ugly. Unlearning
> might be even harder...
Hi.
Just wanted to step in, say that I agree with most of the things said
about breaking the api, and since we are doing such a great change,
it could also be a good moment to take a look at all the api as a whole
and rename the functions to have coherent naming.
If you don't get what I am talking about, please open the Allegro
documentation section Text Output and look at the function names: some
use underscores to separate words (text_mode), some don't (textout),
some do but only at specific places (textprintf_centre). The ordering
of parameters is also a nice idea too.
It could also be a good moment to unificate the common verbs used to
create/destroy structures (which are practically objects) or their order
in function names; can't think of an example right now but there surely
are some (or was that the spaghetti code I write at work :)?
All of this in the hope that a well thought convention can lead to use
less memory muscle and more logic thinking to remember function names
and ease programming.
--
Grzegorz Adam Hankiewicz gradha@xxxxxxxxxx http://gradha.infierno.org/