Re: [AD] Unicode (2)

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


> I vote for the latter. We could call it `ustrsizecopy()' or something
> like that, in order to point out the difference.

Ok, it seems that most people agree to this semantics.
Now about the names and the prototypes:

P1:  char *ustrncpy (char *dest, const char *src, int size);
      char *ustrncat (char *dest, const char *src, int size);
      int usnprintf (char *dest, int size, const char *format, ...);

P2:  char *ustrsizecpy (char *dest, const char *src, int size);
      char *ustrsizecat (char *dest, const char *src, int size);
      int ussizeprintf (char *dest, int size, const char *format, ...);

P3:  char *ustrsizecpy (char *dest, int size, const char *src);
      char *ustrsizecat (char *dest, int size, const char *src);
      int ussizeprintf (char *dest, int size, const char *format, ...);

I think P2 is a little bow-legged.

--
Eric Botcazou
ebotcazou@xxxxxxxxxx



Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/