[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
Vincent Penquerc'h <vincent@xxxxxxxxxx> wrote:
> > Hmm, I don't like it. You could use `_mouse_sprite' to get the
> > current sprite, copy it, adjust the colours, and set it with
> > `set_mouse_sprite'. Too bad `_mouse_sprite' is internal. Perhaps
> > rename it to `mouse_sprite' and expose it, or create a
> > `get_mouse_sprite' function?
>
> access to the mouse sprite would be a good thing, IMHO, and would
> not add any spam to the lib. It is necessary to get ai this info
> (including the focus point) to draw the cursor yourself, and I
> found you pretty much have to do it if you want to avoid flicker
> (or you have to go through hacks using show_mouse ...)
If we follow the current mouse API, which has:
mouse_x, mouse_y, mouse_z, mouse_b, mouse_pos
- read only, with setter functions
then I suppose we should have:
mouse_sprite
- read only, with setter function
mouse_sprite_focus_x, mouse_sprite_focus_y
- read only, with setter functions
or follow the current naming:
mouse_x_focus, mouse_y_focus
or follow the mouse_[xyzb] naming:
mouse_focus_x, mouse_focus_y
or ...
Comments?