Re: [eigen] New indexing/slicing API: almost ready to be merged

[ Thread Index | Date Index | More Archives ]

> On 19 Jan 2017, at 10:03, Gael Guennebaud <gael.guennebaud@xxxxxxxxx> wrote:
> We definitely need another name. I though that the following would be ok:
> [...]
> So I propose to:
> 1) Eigen::placeholders::all   -->  Eigen::All
> 2) move last/end to Eigen::Symbols
> any better suggestions welcome!!

in my opinion, the slicing syntax should be kept separate from the ‘middleware’ matrix slicing logic ( eg, blocks, etc.)
to give the user the ability to choose his preferred method, and to give you Eigen devs the ability to support different
competing slicing syntaxes ( or user via plugins ).
So, I’d put all slicing related 'symbols’  in dedicated namespaces, eg

etc …

Mail converted by MHonArc 2.6.19+