|Re: smalleset() ( Re: [eigen] Householder.h: ::min() and operator<=)|
[ Thread Index |
| More lists.tuxfamily.org/eigen Archives
Am 12.09.2016 um 10:57 schrieb Christoph Hertzberg:
If nobody objects against that, I'll patch this into the dev-branch. Especially, are there objections against or alternative suggestions for the naming? `lowest()` probably would be a bad choice, since this is what std calls what
we call `min()`.
The problem with std::min() is, that it has to be understood historically. The name is a bad choice,
since the behaviour is different for integer and floating point values .
> N.B.: The 1 must be T(1) here (in case T is not implicitly constructible from int). And perhaps we should document it as "lowest non-denormalized positive value".
Which would suggest lowest() as a name, which is however already used.