[eigen] Opinions on some minor features for 3.2 |
[ Thread Index |
Date Index
| More lists.tuxfamily.org/eigen Archives
]
- To: eigen <eigen@xxxxxxxxxxxxxxxxxxx>
- Subject: [eigen] Opinions on some minor features for 3.2
- From: Gael Guennebaud <gael.guennebaud@xxxxxxxxx>
- Date: Wed, 20 Mar 2013 16:26:24 +0100
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20120113; h=x-received:mime-version:from:date:message-id:subject:to :content-type; bh=gzA1u8rT6HVSoVmq9Jtt2Fivl4oJ5SMOi7kmx2UQCkU=; b=hyyoDuXauCRTAwqHLbnyA2CnjhZB2L0uKL+RhGpWtH5By8zKNOf1WNR1r6eEcAQTlp Hj/YhrwFRFmNr3+SruqoqmNQIh844SJ593XDhEflVuAOZJnq/rTpdybPbCAU3wj3hXbY 5lcOFXPrPzP9XhdZw7g9H8rRC2vYHVCfU8i3dyDjZvAbn5VGxohdhS1VsRBevX7j+onI XCghWabfaQ2G0iX9gZ4VXBWEgigo7pwWgBwH3hAVFeTENeuySXki148jBg9305iMfx6N S/bm+uIUmm+qLovmsIRfgVNrL4KI9heN/GggXe+TtlH16Qnw9g5H5MHNz9p0nAf2i+hY H/6w==
Hi,
Since a beta for 3.2 has already been released, we should limit as
much as possible the new features in 3.2 to make sure we can release
it asap. However there are few minor ones that I'd like to suggest.
Please give your opinion.
1 - Add support for the following products: SelfadjointView * Sparse
and Sparse * SelfadjointView
This is straightforward to add because there is no obvious solution
than evaluating the SelfadjointView into a full SparseMatrix. This
copy will be documented. This copy is not a big deal from my point of
view because SparseMatrix * SparseMatrix already require many explicit
transpositions in most cases.
(see http://eigen.tuxfamily.org/bz/show_bug.cgi?id=553)
2 - Make the sparse inner iterator copyable -> trivial and harmless
change; This is useful to store a list of iterators.
(see http://eigen.tuxfamily.org/bz/show_bug.cgi?id=557)
3 - Regarding this second change and related bug report, I also
proposed to add new members to sparse InnerIterators:
a) add a pos() member returning the number of non-zeros that have been
iterated on
b) add a += operator to skip many non-zeros at once.
That's easy to add, but I'm not really sure about it. Clearly the name
"pos" is not good, but perhaps we could wait for a clear need for
that.
Feel free to extend this discussion with other suggestions too.
cheers,
Gael.