[eigen] cwise ops nomenclature

[ Thread Index | Date Index | More lists.tuxfamily.org/eigen Archives ]

Hi eigen developers,

   This suggestion might be a little presumptuous but here it is anyway: I 
think cwise<Op>() member functions could be better understood and remember if 
renamed to ewise<Op>() or elemwise<Op>() or elementwise<Op>(). Here is why I 
think so:

1. I keep getting dragged into thinking that cwise<Op>() is column-wise as 
opposed to coefficient-wise. I think this is because I was introduced to 
cwise... and colwise() on the same day when I read the Eigen tutorial page. 
This might be the case with others who get introduced to Eigen.

2. The contents of matrices and vectors are usually referred to as elements 
more than coefficients. A "coefficient" is an entity that usually accompanies 
something else (as a multiplicative factor). In this sense, matrices (which 
are representations of linear operators in a certain basis) often are the 
coefficients themselves in a polynomial or multidimensional ODE (resulting 
from discretization of PDEs). I do suppose the elements of a matrix can be 
called coefficients because they do multiply components of vectors to whcih 
they are applied ...


Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/