Re: [eigen] solve with and without check

[ Thread Index | Date Index | More Archives ]

> --> i propose the following change:
> in all decompositions that have a solve() checking for existence,
> let's rename solve() to solveWithCheck()   (or whatever native English
> speakers prefer... perhaps trySolve() ? checkSolve() ? )
> then let's add a method solve() that doesn't do any check, making it
> the responsibility of the caller that a decent solution exists.

Or the opposite.
For example if one want to access to a matrix without control, has to use the coeff() or coeffRef() 
methods, while the operator() (i.e. the primary choice) makes a control. In order to ensure the 
consistency with the other parts of Eigen, the solve() method should make a control, while another 
method (solveWithoutCheck() or whatever) should return the solution without performing the check.

Andrea Arteaga

Mail converted by MHonArc 2.6.19+