[eigen] API change proposal |
[ Thread Index |
Date Index
| More lists.tuxfamily.org/eigen Archives
]
Hi all,
I propose to switch the solve() method from LU from the signature
bool solve (const MatrixBase< OtherDerived > & b, ResultType * result) const
to
bool solve (const MatrixBase< OtherDerived > & b, ResultType & result) const
This is
a) more C++-like
b) doesn't shoot with wild pointers.
I'm using 2.0.3, so if this is already in the development branch, forget about
this mail. Opinions?
Greetings,
Markus