|Re: [eigen] patch for tridiagonal matrices in eigen|
[ Thread Index |
| More lists.tuxfamily.org/eigen Archives
- To: eigen@xxxxxxxxxxxxxxxxxxx
- Subject: Re: [eigen] patch for tridiagonal matrices in eigen
- From: "Benoit Jacob" <jacob.benoit.1@xxxxxxxxx>
- Date: Mon, 15 Dec 2008 08:59:50 -0500
- Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to :subject:in-reply-to:mime-version:content-type :content-transfer-encoding:content-disposition:references; bh=dLbIuSCVcQaVr7J60fqV6t1OH8kAKi7seyUZlIQOQik=; b=sJfYBaPW69hVAGbAnAVJ6tZ4M7xFkoZvwoS7ghOOn0yy2/V4o9qHawxeXH48uxROQs MwL/bsoepH1vTmgBrFAmM9czM9ctJnnjOasSeenVpTNX2oq1jqwH2x3U5ofok2lT0nP/ 7XzBnnUI72bCuJRl3u4Cbzg90TW83mn4T852g=
- Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=message-id:date:from:to:subject:in-reply-to:mime-version :content-type:content-transfer-encoding:content-disposition :references; b=B8yPxNkHTtMYU2KjkvpZayYUo6OdPQb8CXXOnpijjv5Mt0s/9tttf1o9n+1DRbUXBP 6/GEtj7wc1z2JxtNZqXJmqbLAlCX+O607Zk5327E8fB5gcBEvj/W+HGHnglhZWdoCHhv 0kB5+4fqjIHh0LEN2uyZmS4WQWkYXAmFKrseM=
>>> -const unsigned int Upper = UpperTriangularBit;
>>> -const unsigned int StrictlyUpper = UpperTriangularBit | ZeroDiagBit;
>>> -const unsigned int Lower = LowerTriangularBit;
>>> -const unsigned int StrictlyLower = LowerTriangularBit | ZeroDiagBit;
>>> +const unsigned int Upper = UpperTriangularBit | UpperHessenbergBit;
>>> +const unsigned int StrictlyUpper = Upper | ZeroDiagBit;
>>> +const unsigned int Lower = LowerTriangularBit | LowerHessenbergBit;
>>> +const unsigned int StrictlyLower = Lower | ZeroDiagBit;
>>> here I don't really follow. These are parameters for part(). So unless
>>> you want to add Hessenberg support in part (which would be a good
>>> idea) no need to change that. If you want to add Hessenberg support,
>>> you need to make the corresponding changes in Part.h.
>> I saw that the product helper checked for diagonals using the flags,
>> so I did the same for tridiagonals.
> OK right, sorry. These are always convenient shortcuts. What needs to
> be updated then is the comment saying that these are the parameters
> for part(), actually they're not used only for part().
Wait, no, I answered too fast. We really can't do such a thing as
+const unsigned int Upper = UpperTriangularBit | UpperHessenbergBit;
for example how would we then in part() distinguish between upper
triangular and upper hessenberg...
the real problem is that in the first place we allowed ourselves this
silly shortcut Upper for upper triangular. Now that there is upper
hessenberg too, this is getting ambiguous. I think we just rename
Upper to UpperTriangular and then we add UpperHessenberg alongside.
Yes this is an incompatible API change, there's a reason why we
haven't released yet. KDE / KOffice is not affected, as far as I can