Re: [AD] al_toggle_display_flag ALLEGRO_NOFRAME

[ Thread Index | Date Index | More Archives ]

On Sun, 4 Mar 2012 12:01:45 +1100
Peter Wang <novalazy@xxxxxxxxxx> wrote:

> Hi,
> Why is the verb "toggle" instead of just "set"?
> 5.1 adds al_toggle_menu_item_flags -- that should be reconsidered.

Can we rename it to al_set_display_flag?

> The NOFRAME flag is just confusing.  Both the Windows and X11
> implementations got al_toggle_display_flag(ALLEGRO_NOFRAME) wrong.
> Unfortunately we have a few negative flags already, but we should
> avoid adding more.

I don't think they are so bad, else we get confusion with some of the
flags being on by default and others off. Right now (I think) they are
all off by default. In this particular case something like
ALLEGRO_BORDERLESS might be better. But it's also negative so don't

Mail converted by MHonArc 2.6.19+