[AD] config function naming |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
Elias brought up the example of naming of the config functions,
so let's try to fix that:
al_config_add_comment -> al_add_config_comment
al_config_add_section -> al_add_config_section
al_config_create -> al_create_config
al_config_destroy -> al_destroy_config
al_config_get_value -> al_get_config_value
al_config_merge -> al_merge_config
al_config_merge_into -> al_merge_config_into
al_config_read -> al_load_config_file
al_config_set_value -> al_set_config_value
al_config_write -> al_save_config_file
I'm not sure about al_merge_config/al_merge_config_into. al_merge_config
doesn't suggest it returns a new config. More importantly, though, the
behaviour of the function is a little bit complex as it's not obvious what
to do with comments so we don't keep comments from the second config
structure at all. "Merge" might not be the best word.
Peter