[AD] al_verb_noun

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


I spotted a few (new?) cases where the function names seem to deviate from the guidelines:

al_ustr_new (should be al_create_ustr or al_create_ustring?)
al_ustr_new_from_buffer
al_ustr_free
al_cstr  (al_convert_to_cstring?)
al_cstr_dup (what's the difference with the previous function?)
al_ustr_dup (al_duplicate_ustring?)

etc. for the other string functions. May make sense to wait until they are all implemented (the comments in the file indicate some functions still need to be added).

also (from utf8.h),

struct ALLEGRO_USTR_INFO {
/* This struct needs to be at least as big as struct _al_tagbstring. */
   int __pad[4];
};

might I suggest that in light of that comment this should then be
struct ALLEGRO_USTR_INFO {
   struct _al_tagbstring __dummy;
};
or something similar? Or am I missing something?

Along similar lines:

al_path_create
al_path_clone (should this be called "duplicate", as in the string API?)

al_path_num_components (needs get?)
al_path_index (needs better name)
al_path_free
al_path_emode (needs better name, I read it as "al_path_emote")

Evert




Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/