Re: [AD] proposed changes to sound API |
[ Thread Index |
Date Index
| More lists.liballeg.org/allegro-developers Archives
]
On 2008-12-16, Matthew Leverton <meffer@xxxxxxxxxx> wrote:
> Before I submit any smaller patches, I'd like to propose some bigger
> changes to the sound API.
>
> http://wiki.allegro.cc/NewAPI/Sound/Proposed
>
> I don't like how the "simple" layer is made to be an all/or nothing
> thing. If the regular API is too difficult, then it is designed wrong.
> The changes I'm proposing would remove the distinction between the two
> layers while keeping the current behavior almost the same. In short:
I like it.
>
> * Rename al_setup_simple_audio() to al_reserve_sample_slots().
>
> * Provide methods to get/set the default mixer.
>
> * Rename ALLEGRO_SAMPLE to ALLEGRO_SAMPLE_PLAYER
ALLEGRO_SAMPLE_INSTANCE would be the clearer. Since most users won't
have to deal with them under your design, it's probably not too long.
> * Rename ALLEGRO_SAMPLE_DATA to ALLEGRO_SAMPLE
>
> * Support WAV files out of the box.
al_stop_sample() -> al_stop_sample_instances()
Peter