[AD] Renaming of functions in kcm_audio addon

[ Thread Index | Date Index | More lists.liballeg.org/allegro-developers Archives ]


As discussed previously, I've renamed all the kcm_audio addon functions so the naming convention in the addon is the same as in the rest of the library: al_verb_noun. The following is a list of the renamed functions. If no one objects to any of these changes (or has alternative suggestions), I'll commit the change tomorrow or the day after.

Evert

Renamed functions (old_name new_name)

/* Sample data functions */
al_sample_data_create      al_create_sample_data
al_sample_data_destroy     al_destroy_sample_data

/* Sample functions */
al_sample_create           al_create_sample
al_sample_destroy          al_destroy_sample
al_sample_get_long         al_get_sample_long
al_sample_get_float        al_get_sample_float
al_sample_get_enum         al_get_sample_enum
al_sample_get_bool         al_get_sample_bool
al_sample_get_ptr          al_get_sample_ptr
al_sample_set_long         al_set_sample_long
al_sample_set_float        al_set_sample_float
al_sample_set_enum         al_set_sample_enum
al_sample_set_bool         al_set_sample_bool
al_sample_set_ptr          al_set_sample_ptr
al_sample_set_data         al_set_sample_data
al_sample_play             al_play_sample
al_sample_stop             al_stop_sample

al_stream_create              al_create_stream
al_stream_destroy             al_destroy_stream
al_stream_drain               al_drain_stream
al_stream_get_long            al_get_stream_long
al_stream_get_float           al_get_stream_float
al_stream_get_enum            al_get_stream_enum
al_stream_get_bool            al_get_stream_bool
al_stream_get_ptr             al_get_stream_ptr
al_stream_set_long            al_set_stream_long
al_stream_set_float           al_set_stream_float
al_stream_set_enum            al_set_stream_enum
al_stream_set_boo             al_set_stream_bool
al_stream_set_ptr             al_set_stream_ptr
al_stream_rewind              al_rewind_stream

/* Mixer functions */
al_mixer_create               al_create_mixer
al_mixer_attach_sample        al_attach_sample_to_mixer
al_mixer_attach_stream        al_attach_stream_to_mixer
al_mixer_attach_mixer         al_attach_mixer_to_mixer
al_mixer_get_long             al_get_mixer_long
al_mixer_get_enum             al_get_mixer_enum
al_mixer_get_bool             al_get_mixer_bool
al_mixer_set_long             al_set_mixer_long
al_mixer_set_enum             al_set_mixer_enum
al_mixer_set_bool             al_set_mixer_bool

/* Voice functions */
al_voice_create               al_create_voice
al_voice_destroy              al_destroy_voice
al_voice_attach_sample        al_attach_sample_to_voice
al_voice_attach_stream        al_attach_stream_to_voice
al_voice_attach_mixer         al_attach_mixer_to_voice
al_voice_detach               al_detach_voice
al_voice_get_long             al_get_voice_long
al_voice_get_enum             al_get_voice_enum
al_voice_get_bool             al_get_voice_bool
al_voice_set_long             al_set_voice_long
al_voice_set_enum             al_set_voice_enum
al_voice_set_bool             al_set_voice_bool

/* Misc. audio functions */
al_audio_init                 al_install_audio
al_audio_deinit               al_uninstall_audio

al_is_channel_conf            al_channel_is_configured
al_channel_count              al_channel_count
al_depth_size                 al_depth_size





Mail converted by MHonArc 2.6.19+ http://listengine.tuxfamily.org/